侧边栏壁纸
博主头像
liveJQ博主等级

沒有乐趣,何来开始

  • 累计撰写 148 篇文章
  • 累计创建 61 个标签
  • 累计收到 2 条评论

yum依赖包版本冲突问题

liveJQ
2023-09-20 / 0 评论 / 0 点赞 / 156 阅读 / 434 字 / 正在检测是否收录...
广告 广告

yum 配置了本地源,安装 glance 报错。

Requires: python = 2.7.5-93.el7_9
Installed: python-2.7.5-94.el7_9.x86_64 (@updates)

根据建议使用--skip-broken尝试无果后,直接删除已安装的高版本软件包,加上--nodeps选项表示忽略软件包的依赖问题。这两个软件包是一起的,降级的话需要一起回退。

rpm -e --nodeps python-2.7.5-94.el7_9.x86_64
rpm -e --nodeps python-libs-2.7.5-94.el7_9.x86_64

由于 yum 命令依赖于python,所以后续安装只能通过手动上传软件包进行安装。

rpm -i python-2.7.5-93.el7_9.x86_64.rpm python-libs-2.7.5-93.el7_9.x86_64.rpm

相关资料

  1. Index of /pub/centos/7/updates/x86_64/Packages
0

评论区